IRCNow

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
openbsd:openhttpd [2019/11/10 11:46]
jrmu
openbsd:openhttpd [2019/11/21 13:21]
jrmu removed
Line 44: Line 44:
 </​code>​ </​code>​
  
-Make sure pf allows incoming http connections:​+Make sure pf allows incoming http connections ​by putting this line into /​etc/​pf.conf:
  
 <​code>​ <​code>​
 pass in proto tcp to port {http https} pass in proto tcp to port {http https}
 +</​code>​
 +
 +Then, reload the pf rulesets:
 +
 +<​code>​
 +$ doas pfctl -f /​etc/​pf.conf
 +</​code>​
 +
 +At this point, you should test to see if the web server is working on port 80. This test should be run on some other computer besides the web server (your local workstation is fine). Make sure you have curl installed:
 +
 +<​code>​
 +$ doas pkg_add curl
 +$ curl example.com
 +</​code>​
 +
 +You should a response similar to the one below:
 +
 +<​code>​
 +<​!DOCTYPE html>
 +<​html>​
 +<​head>​
 +<meta http-equiv="​Content-Type"​ content="​text/​html;​ charset=utf-8"/>​
 +<​title>​302 Found</​title>​
 +<style type="​text/​css"><​!--
 +body { background-color:​ white; color: black; font-family:​ 'Comic Sans
 + ​MS',​ '​Chalkboard SE', 'Comic Neue', sans-serif; }
 +hr { border: 0; border-bottom:​ 1px dashed; }
 +
 +--></​style>​
 +</​head>​
 +<​body>​
 +<​h1>​302 Found</​h1>​
 +<hr>
 +<​address>​OpenBSD httpd</​address>​
 +</​body>​
 +</​html>​
 </​code>​ </​code>​
  
Line 60: Line 96:
 <​code>​ <​code>​
 $ openssl s_client -connect example.com:​443 $ openssl s_client -connect example.com:​443
-<​code>​+</code>
  
 You should see the correct SSL subject and issuer: You should see the correct SSL subject and issuer:
  
 <​code>​ <​code>​
-subject=/​CN=test.ircnow.org+subject=/​CN=example.com
 issuer=/​C=US/​O=Let'​s Encrypt/​CN=Let'​s Encrypt Authority X3 issuer=/​C=US/​O=Let'​s Encrypt/​CN=Let'​s Encrypt Authority X3
 </​code>​ </​code>​