IRCNow

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
openbsd:openhttpd [2019/11/11 05:27]
jrmu
openbsd:openhttpd [2019/11/21 13:21]
jrmu removed
Line 56: Line 56:
 </​code>​ </​code>​
  
-Now you will almost certainly want openhttpd ​to use an SSL cert, so follow ​the [[openbsd:​acme-client|acme-client]] instructions,​ then reset your web server:+At this point, ​you should test to see if the web server ​is working on port 80. This test should be run on some other computer besides the web server (your local workstation is fine). Make sure you have curl installed:
  
 <​code>​ <​code>​
-$ doas rcctl restart httpd+$ doas pkg_add curl 
 +$ curl example.com
 </​code>​ </​code>​
  
-At this point, you should ​test to see if the web server is working on port 80. This test should be run on some other computer besides the web server (your local workstation is fine).+You should ​a response similar ​to the one below:
  
 <​code>​ <​code>​
-$ nc example.com 80 +<​!DOCTYPE html> 
-GET index.html HTTP/1.1 +<html
-HOSTexample.com+<​head>​ 
 +<meta http-equiv="​Content-Type"​ content="​text/html; charset=utf-8"/>​ 
 +<​title>​302 Found</​title>​ 
 +<style type="​text/​css"><​!-- 
 +body { background-colorwhite; color: black; font-family:​ 'Comic Sans 
 + ​MS',​ '​Chalkboard SE', 'Comic Neue', sans-serif; } 
 +hr { border: 0; border-bottom:​ 1px dashed; } 
 + 
 +--></​style>​ 
 +</​head>​ 
 +<​body>​ 
 +<​h1>​302 Found</​h1>​ 
 +<​hr>​ 
 +<​address>​OpenBSD httpd</​address>​ 
 +</​body>​ 
 +</​html>​
 </​code>​ </​code>​
  
-You should a response similar ​to the one below:+Now you will almost certainly want openhttpd ​to use an SSL cert, so follow ​the [[openbsd:​acme-client|acme-client]] instructions,​ then reset your web server:
  
 <​code>​ <​code>​
-HTTP/1.0 408 Request Timeout +$ doas rcctl restart ​httpd
-Date: Mon, 11 Nov 2019 05:06:06 GMT  +
-Server: OpenBSD ​httpd        +
-Connection: close  +
-Content-Type:​ text/​html ​         +
-Content-Length:​ 439+
 </​code>​ </​code>​
- 
-s_client -connect example.com:​443 
  
 To test if your web server is working and has a correct SSL cert, run: To test if your web server is working and has a correct SSL cert, run:
Line 92: Line 101:
  
 <​code>​ <​code>​
-subject=/​CN=test.ircnow.org+subject=/​CN=example.com
 issuer=/​C=US/​O=Let'​s Encrypt/​CN=Let'​s Encrypt Authority X3 issuer=/​C=US/​O=Let'​s Encrypt/​CN=Let'​s Encrypt Authority X3
 </​code>​ </​code>​