Pxeboot /
Configure pxeboot
First, in the client machine, go to the BIOS setup and enable PXE booting. In this example, we will configure all machines on the subnet to use boot OpenBSD by default. If you want to customize the specific boot device, you will want to note the MAC address of the network card that will be connecting to the DHCP server.
Specify the filename
subnet 10.0.0.1 netmask 255.255.255.0 { option routers 10.0.0.1; option domain-name-servers 10.0.0.1; filename "pxeboot"; next-server 10.0.0.1; host ircnow.org { fixed-address 10.0.0.2; hardware ethernet aa:bb:cc:dd:ee:01; } }
# mkdir /var/tftpboot # cp /usr/mdec/pxeboot /bsd.rd /var/tftpboot/ # chmod 444 /var/tftpboot/{pxeboot,bsd.rd} # echo 'tftpd_flags="-v /var/tftpboot"' >> /etc/rc.conf.local # rcctl restart tftpd